Monday, June 13, 2011

Installing the shitty Amazon MP3 downloader on Ubuntu Lucid

While it sucks to have to use a MP3 downloader app at all, it's good Amazon actually has a linux version (it wasn't always the case). But it is a shame they did such a bad job of it. They wrote the downloader for Ubuntu Jaunty (now a number of releases old) and haven't updated it since.

The correct way to distribute this app would have been to provide a PPA you could put in your apt sources, which would be updated for each new version of Ubuntu, and allow the full package management capability. By using .debs any dependencies need to be manually satisfied, and you can't push updates or bug-fixes, although it looks like Amazon has written that functionality into the program itself. The deb also depends on very specific versions of libboost, rather than just specifying a minimum version number, which would allow it to work on later releases.

So installing it on lucid, or any other version is a bit of a pain. Here is one solution, that grabs the original dependencies from launchpadlibrarian and installs them:

wget \ \ \ \ \ \
sudo dpkg -i *.deb
sudo dpkg -i amazonmp3.deb